JDK8とScene Builder 1.0の併用不可?

(7/25追記)

この件はJDK 8インストール時にPublic JREのインストールをはずしておけば大丈夫だった。

a

 

他にもちょこちょこ触っていたので濡れ衣かもしれないけどもWindwos7の64bitではJDK 8(EA)とScene Builder 1.0の併用は単純には不可っぽい。

64bit版Windows7にてJDK 8(Early AccessのBuild b98)をインストールした翌日に、Scene Builder 1.0を起動しようとしたところ起動できなくなっていた。

java -versionで1.8を呼んでいるので

JAVA_HOME=C:\Program Files\Java\jdk1.7.0_25
Path=C:\Program Files\Java\jdk1.7.0_25\bin;~

な感じに環境変数をセットして1.7にパスを通しなおしてみたけどだめ。

レジストリのHKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime EnvironmentをみるとCurrentVersionに1.8とかレジストリはいろいろ書いてある。

scenebuilder.exeなのでそっちを見てうまくいかないのかな??

ということで、JDK 8(とアプリ的には別にインストールされていたJRE 8)をアンインストールしたら無事に起動できた。

濡れ衣かも知れないけどそういうことと思っておこう。。。。

 

1 thought on “JDK8とScene Builder 1.0の併用不可?

  1. ピンバック: NetBeans IDE 7.4 Beta | あらぶるトラブル

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です