Eclipse(Pleiades)でJDK8

エクリプスのWikiをみてみるとJDK8用のパッチがリリースされている。

というわけで早速入れてみる。

今回の環境は4.3.2ベースのPleiades。Lunaでもいけるらしい。

まず、インストール前の素の状態。

インストール済みJREには設定できるけどランタイムには指定できない。

1

2

 

新規ソフトウェアの追加から次へ次へと行けばいい模様。

Help > Install New Software...
enter the following URL into the 'Work with' field:
http://download.eclipse.org/eclipse/updates/4.3-P-builds/

きっとこれやれば8の指定ができるってことなのだろうとインストールしようとしたら。

3

 

で、依存関係の計算で止まってしまった。

4

 

しばらく放置して進むか確認してみます。。。

っということで放置していたら動きました。

実行環境で8選べるようになってます。

 きしださんのソースをコピらせていただいて軽く動作確認。

package hoge;

import java.util.Arrays;
import java.util.List;

public class Fuga {
	public static void main(String... args){
	    List<String> strs = Arrays.asList("hoge", "foo", "yeah");
	    System.out.println(strs.toString());

	    strs.replaceAll(t -> "** " + t + " **");
	    System.out.println(strs.toString());
	}
}

とりあえず動いているっぽい。

あとは隙間を見つけて。

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です